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Presentation to the Melbourne PC Users Bayside SIG 

by Kathy Rouse 15th June 2006....    

    
Paint.NET, the free program begun as an undergraduate senior design project at Washington State 
University, by Microsoft, is currently being maintained by some of the original creators. It is intended as a 
replacement for the limited Paint program that comes with Windows. 

Paint.NET is an image and photo manipulation program that supports layers, unlimited undo, special effects 
and a number of tools and effects. The latest, version, 2.63, is designed to be run on Windows 2000, XP, 
Vista and Server 2003. Information about the program and how to download it can be found at: - 
http://www.eecs.wsu.edu/paint.net/pdnabout.html. 

You must have Microsoft.Net Framework 2.0 on your computer before you can install Paint.Net. 

Work is currently being done on version 3.0 to be released around the time Vista comes on the market. 
Updates to 2.6, for the most important bugs, will continue to be released from time to time. I have found the 
latest version to be amazingly stable on my computer – Pentium 4 CPU 2.40GHz, 1.00 of RAM. 

It is planned that version 3.0 will include the following, 
� Intuitive multi-document user interface 
� More intuitive and more powerful toolbar 
� Enhanced user experience in Windows Vista 
� Adjustment layers 
� Layer masks 
� Gradient drawing 
� Metadata editor(per-image, and per-layer) 
 

Paint.Net comes with a help file and there is an on-line forum for tutorials and discussion. Apart from the 
Gimp it does not seem to have many rivals as far as freebies is concerned.  

A GUIDE TO USING PAINT.NET 

The following is intended as an introduction to Paint.Net and an explanation of how to use the main tools. It is 
not meant as a guide to fixing images, because I am still very much a beginner in this area. More information 
can be obtained from the material in the Help file, and the tutorials and helpful hints in the on-line Forum. 

Those of you, who have already done some editing with Photoshop or other imaging programs, will find it 
much easier than those just starting out. If you don’t want to do any more than a slight tweaking, 
straightening and cropping of your photos then a program like Picasa is probably all you really need. If you 
want more control over the results, you need an imaging and photo manipulation program like Paint.Net. 

STARTING AT THE BEGINNING 

 Open the program by clicking on the Paint.Net icon on your desktop or go to Start>All programs>Paint.NetStart>All programs>Paint.NetStart>All programs>Paint.NetStart>All programs>Paint.Net. 
The program opens with a blank page and 4 floating utility windows – Tools, History, LayersTools, History, LayersTools, History, LayersTools, History, Layers and ColorsColorsColorsColors.... If 
you don’t see these, go to WindowsWindowsWindowsWindows in the menu bar and select them from the drop down menu. These 
palette windows can be made translucenttranslucenttranslucenttranslucent by ticking that option in the drop down menu.  

I recommend that before you look at the following projects you familiarise yourself with the menu and tool 
items and their functions. Click on HelpHelpHelpHelp in the Menu bar and then on Help topicsHelp topicsHelp topicsHelp topics or you can hit the F1 keyF1 keyF1 keyF1 key on 
your keyboard. In the help pages, clicking on any of the items listed on the left-hand side will present you with 
a page explaining what the item is and its use. 

When you select any of the tools in the tools tools tools tools palettepalettepalettepalette a brief tool tip will appear in the status bar at the bottom 
of the main window giving you the name of the tool, what it does  and how to use it. 

I have put together a Step-by-step guide for 3 projects to show you how I have used the program. As with any 
computer software there is always more than one way of doing things.  
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PROJECT ONE 

USING THE PAINT TOOLS TO DRAW 

To help you become familiar with the use of some of the drawing tools in Paint.NET, I thought I would start by 
creating a simple object, a computer. 

1.1.1.1. With the program open and before doing anything creative, go to File>SaveFile>SaveFile>SaveFile>Save and save this project 
as “A Computer.” 

2.2.2.2. In the tools palette select the rectangle shape tool, on the left second up from the Tolerance. 
Option. Notice that the toolbar under the Menu window has some shape outlines and if you move 
your mouse over these you will get the following tool tips – Draw shape outline, Draw filled shape and 
Draw filled shape with outline. 

3.3.3.3.  Click on the last one of these to draw a filled box with a border. Put a value of (6666) in the box next 
to brush widthbrush widthbrush widthbrush width.  

4.4.4.4. On the colour swatches at the bottom of the tools window click on the white square which 
displays the secondary colour, and then in the Colors Colors Colors Colors window select a shade of grey. The secondary 
colour now shows the grey you picked. 

5.5.5.5. Now go to the drawing area and left mouse click and drag across and down the screen until you 
have the shape you want and let go. Draw another rectangle underneath the larger one, thinner and 
shorter than the first. This will represent the monitor stand.  

6.6.6.6. Under the colour swatches click on the tiny black and white boxes which will restore the primary 
and secondary colours to their default settings Click on the rounded rectangle to the right and drag 
another rectangle inside the larger box representing the monitor screen.  

7.7.7.7. Select the Text tool (AText tool (AText tool (AText tool (A).).).). Choose your font. I have chosen Arial Black and a size of 20. Click in 
the monitor screen where you want your text to start and type the words – “A COMPUTER”.  

8.8.8.8. When you move your mouse over the flashing arrows to the lower right of the text your pointer 
turns into a hand and you can position the text where you want by dragging. At this point you can still 
change the font attributes or backspace and retype your letters. 

9.9.9.9. Click on the primary color swatch and choose a red. Your text will now turn red. 

10.10.10.10. Click anywhere else on the window to finish your project. Now save your project. (Paint.NET 
does not do any automatic saving so it is a good idea to regularly save your work so you don’t lose it 
if something goes wrong.) You should now have something that looks like this. 

 

 

 

 

 

 

 

 

 

 

 

 

This simple example is OK, but a little plain, and if you want to go back and change any of the drawing 
elements you will pretty much have to start again from scratch. 

This is where the magic and versatility of layerslayerslayerslayers comes in. I must admit, after getting stuck into this 
program, I now use layers for just about everything I do to a picture.  

 



 3 

PROJECT TWO 

USING LAYERS TO DRAW MORE CREATIVELY 

1.1.1.1. Open Paint.NET, or if you already have it open, go to File>NewFile>NewFile>NewFile>New. 

2.2.2.2. Go to File>SaveFile>SaveFile>SaveFile>Save and Save this project as “A Computer Using Layers”A Computer Using Layers”A Computer Using Layers”A Computer Using Layers”. Double click the 
Background layer in the Layers WindowLayers WindowLayers WindowLayers Window and, in the Layer Properties Layer Properties Layer Properties Layer Properties box that appears rename this 
layer “White Background.”White Background.”White Background.”White Background.” Click OKOKOKOK 

3.3.3.3. In the layers window, click on the little icon at the bottom with the + on it to add a new blank 
layer. You won’t see any changes on the image canvas because this layer is transparent. Double 
click the new layer, which is now highlighted, and call it “Computer Computer Computer Computer BoxBoxBoxBox””””. Click OK.OK.OK.OK.    Draw a rectangle 
representing a Computer Box as we did in Steps 2 to 5 in the first project. 

4.4.4.4.  Go to File>SaveFile>SaveFile>SaveFile>Save and this time you will get a  Save AsSave AsSave AsSave As dialogue boxdialogue boxdialogue boxdialogue box because the program will 
now save the file in the pdn file formatpdn file formatpdn file formatpdn file format which is the lossless Native file format used by Paint.NET to 
preserve the layers. Save the file with the same name we used before – “A Computer Using Layers.” 

5.5.5.5. In the layers window create a new layer. Double click the new layer, which is now highlighted, 
and call it ““““Computer BaseComputer BaseComputer BaseComputer Base.”.”.”.” Click OKOKOKOK 

6.6.6.6. Making sure that “Computer Base” is still highlighted in the Layers Window; draw another 
rectangle underneath the larger one, as in the earlier project. This will represent the monitor stand. 

7.7.7.7. Add a new blank layer, as you did in step 2, and call it ““““Computer ScreenComputer ScreenComputer ScreenComputer Screen.” .” .” .” Making sure it is 
selected, follow steps four and five from the previous project. 

8.8.8.8. Add another new layer and call it ““““Text LayerText LayerText LayerText Layer.”.”.”.” With the “Text Layer” highlighted follow step 
seven from the previous project. 

AND NOW FOR THE MAGIC OF LAYERS!AND NOW FOR THE MAGIC OF LAYERS!AND NOW FOR THE MAGIC OF LAYERS!AND NOW FOR THE MAGIC OF LAYERS!        
I HOPE THIS DOESN’T GET TOO CONFUSING.I HOPE THIS DOESN’T GET TOO CONFUSING.I HOPE THIS DOESN’T GET TOO CONFUSING.I HOPE THIS DOESN’T GET TOO CONFUSING.    

    

9.9.9.9. To see only the “Computer Box” layer, remove the visibility tick from all the other layers. You can 
leave the White background ticked if you prefer. With the “Computer Box” layer highlighted, choose 
Rectangle SelectRectangle SelectRectangle SelectRectangle Select in the Tools Window, and drag a rectangle around the box. Now select the Move Move Move Move 
Selected PixelsSelected PixelsSelected PixelsSelected Pixels tool, which is the next tool to the right and drag the handle at the top of the rectangle 
down to reduce the height of the box.  
Tips:-If you hold down the shift key and drag on the corner handles you will restrain the proportions 
of your image. Move the mouse inside the selected area and when it turns into an arrow you can 
change its position on the canvas 
The Move SelectionMove SelectionMove SelectionMove Selection tool, beneath the Move Selected PixelsMove Selected PixelsMove Selected PixelsMove Selected Pixels    tool, enables you to resize and re 
position the selection without affecting the image. 
If you find that commands do not seem to be working, make sure that you don’t have any marching 
ants in the window. If so go to Edit>deselect or Ctrl + D. 
You can enlarge the layers window by placing your mouse over the boundaries and when the pointer 
turns into a double arrow click and drag. 

10.10.10.10.  Deselect the selection in the menu bar by going to Edit>DeselectEdit>DeselectEdit>DeselectEdit>Deselect or Ctrl+D.Ctrl+D.Ctrl+D.Ctrl+D. Now tick all the 
layers to make them visible.  

11.11.11.11. Highlight the “Computer Screen” layer and manipulate it in the same way you did the “Computer 
Box” until you have it positioned to your satisfaction. Repeat this with all the layers until the picture 
looks right to you.  
Tip:-You can have any layer visible or invisible at any one time by ticking or removing the ticks, but 
you can only work on one layer at a time, and that is the layer that is highlighted.  
 
Now that you are becoming comfortable using layers, (or are you just completely confused now?), 
you can see that layers give you more control over image manipulation. 

12.12.12.12. Having saved your work, (you didn’t forget to save did you?), get a little more creative. Add a 
new layer and call it ““““ShadowShadowShadowShadow.”””” With “Shadow” highlighted, click on the Rectangle SelectRectangle SelectRectangle SelectRectangle Select tool and 
draw a rectangle around the “Computer box.” Make it just a little larger all round than the box. Use 
the Move SelectionMove SelectionMove SelectionMove Selection tool to fine tune the selection. 
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Still with that selection active, hold down the ctrl key, click on the Rectangle SelectRectangle SelectRectangle SelectRectangle Select tool again and draw 
a contiguous rectangle to cover the “Computer Base”. Once again, have the selection a little outside 
the lines of the computer box and base. Now move the selection (not the pixels) down and to the right 
a little to look something like this. 

 

 

 

 

 

13.13.13.13. “Shadow” layer should still be highlighted. Click the little black & white boxes to restore the 
default foreground and background colours in the tools window. Select the Paint Bucket,Paint Bucket,Paint Bucket,Paint Bucket, move it into 
the selected area, and left click. (If you were to right click, the area would fill with white, the 
secondary colour. Have a play to see what happens.). The selected area should now have turned 
black. Deselect to get rid of the marching ants. 

14.14.14.14. Now you have a black mass over all your good work, which is hardly what you want. Making sure 
that the “Shadow” layer is selected, Click on the Move Layer Down arrowMove Layer Down arrowMove Layer Down arrowMove Layer Down arrow until “Shadow” is just 
above the “White Background” layer. 

15.15.15.15. Still with the “Shadow” Layer selected, go to the Menu BarMenu BarMenu BarMenu Bar and Effects>Blurs>Gaussian BlurEffects>Blurs>Gaussian BlurEffects>Blurs>Gaussian BlurEffects>Blurs>Gaussian Blur – 
and select a blur radius of 15 for the shadow and Click OK. Now, with all the layers ticked, have a 
look at your project. 

16.16.16.16.  Highlight the “Text Layer” and put a rectangle selection around the text. Click on the Move Move Move Move 
Selected PixelsSelected PixelsSelected PixelsSelected Pixels tool and, with the right mouse button pressed, rotate the text to around about a 45

0
 

angle. Adjust its proportions by dragging over the nubs, with the left mouse button pressed, to cover 
the entire computer, not just the screen. 

17.17.17.17. With the “Text” Layer highlighted click on Duplicate Layer Duplicate Layer Duplicate Layer Duplicate Layer at the bottom of the layers window. 
Double click on the new layer, which is the now highlighted top layer in the layers window, and 
rename it “Text Shadow.” Remove the visibility tick next to the “Text” Layer. 

18.18.18.18. Working on the “Text Shadow,” select the Color PickerColor PickerColor PickerColor Picker in the tools window and move the eye-
dropper to just over the red text and right-click. When you do this the secondary color swatch turns to 
the same red you have chosen for the text. 

19.19.19.19. Select the RecolorRecolorRecolorRecolor tool in the tools window. Change the brush size to something like 70 in the 
toolbar at the top of the main window. Holding down the left mouse and moving over the text will 
replace the red, the secondary color in the swatches, with black, the primary color in the swatches. If 
the right mouse button is pressed the reverse occurs. When you have changed the text to black, 
save your work. 

20.20.20.20. With the “Text Shadow” layer highlighted go to Effects > Blurs > Gaussian BlurEffects > Blurs > Gaussian BlurEffects > Blurs > Gaussian BlurEffects > Blurs > Gaussian Blur and choose a 
blur of 10. Move the “Text Shadow” layer below the “Text” Layer and tick the visibility box on the 
“Text” Layer. 

21.21.21.21. Highlight the “Text” Layer and go to Effects > Sharpen Effects > Sharpen Effects > Sharpen Effects > Sharpen and choose an amount of 4, let it render 
and then repeat the process. Your drawing should now look like this- 

 

 

 

 

 

I think it is pretty clear by now that I could go on and on and on, but for the sake of your sanity I will stop now 
and say that we are happy with our creation.  

At this point you can simply save the file and close it so that the layers are preserved and you can come back 
to it later. I have saved it using the SAVE SAVE SAVE SAVE ASASASAS    and called it “Computer “Computer “Computer “Computer Using La Using La Using La Using Layersyersyersyers----FlattenedFlattenedFlattenedFlattened” ” ” ” as a jpeg file. 
This will preserve the project with layers and flatten the project for the JPEG file. 
 
Tip:-Before you flatten an image, make sure that the visibility boxes are ticked on all the layers you want 
included. Otherwise these layers will be discarded. 
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PROJECT THREE 

A PORTRAIT AND MORE ON LAYERS 

For this project, I have chosen to use a group photo, taken at a recent wedding, to make a portrait of my 
mother-in-law. I started with the following photograph:- 

 

 

 

 

 

 

 

 

 

 

1.1.1.1. Choose the ElElElEllipse Selectlipse Selectlipse Selectlipse Select tool and left click and drag to get an oval shape you consider suitable 
to surround your subject. Use the Move SelectionMove SelectionMove SelectionMove Selection    tool to fine tune its location and shape. Then go to 
Image > Crop to SelectionImage > Crop to SelectionImage > Crop to SelectionImage > Crop to Selection. 

2.2.2.2. In the layers window, double click on the Background layer and rename it “Original photo.” Add a 
New Layer and call it “White background.” While it is highlighted use the Paint BucketPaint BucketPaint BucketPaint Bucket to fill it with 
white by right clicking on the image canvas 

3.3.3.3. Highlight the “Original Photo” layer and Click on Duplicate Layer at the bottom of the window. 
Name this layer “Photo Copy” and use the move arrow to move it above the “White background”. 

4.4.4.4. I want the background of the photo to be less distracting so I will need to select my subject. The 
normal tool to use for this is the lasso tool and instructions on how to use it are in the Help file. I have 
found all of the selection tools difficult to use for complicated selections. I discovered an easier way, 
which I will share with you. Anyone wishing to use layers a lot may find this useful even if they have 
better selection tools in their program. 
Click on the Add new layer icon to create a new transparent image and call it “Red mask.” With the 
Red mask layer highlighted, make your primary color a bright red. Choose the PPPPaint brushaint brushaint brushaint brush.... I have 
chosen a pixel width of 2. Zoom in to the picture using the ZoomZoomZoomZoom tool in the Tools palette or the Zoom Zoom Zoom Zoom 
intointointointo tool in the Menu bar. Carefully drag a line around the outline of your subject, clicking the mouse 
at regular intervals so that if you make a mistake the undo won’t take you back too far. Note that you 
are actually painting on a transparent layer that is on top of your photo, not on the actual photo itself. 
If you find that you paint where you should not, either undo or use the EEEErarararaserserserser tool to remove the red. 

5.5.5.5. Once you have the outline where you want you can chose a bigger brush to fill in the mask. It 
may make it easier to have the mask layer slightly transparent to see more clearly where you are 
painting.  
Tip: - To change the transparency of a layer, double click that layer and change the opacity in the 
layers dialogue box. You change the opacity of a layer at any time. 

6.6.6.6. Highlight the “Photo Copy” and, yep you guessed it, make another layer. Click on the Duplicate Duplicate Duplicate Duplicate 
LayerLayerLayerLayer icon and call the new layer “Blurred Background.” This layer needs to be on top of the “Photo 
Copy” and under the “Red Mask.” With the Blurred Background selected go to EffectsEffectsEffectsEffects    >>>>    BlurBlurBlurBlur    
>Gaussian Blur>Gaussian Blur>Gaussian Blur>Gaussian Blur and choose a radius of 10. 

7.7.7.7. Highlight the “Red Mask” layer and make sure the opacity of this layer is at 255. Select the Magic Magic Magic Magic 
WandWandWandWand in the Tools window and click on the red area. The red area and nothing else should now be 
selected. If you don’t get this result you may need to adjust the Tolerance level which is just above 
the color swatches. Now remove the tick on this layer to make it invisible. The marching ants should 
still be visible, so you can see that you have used the red mask to make an accurate selection. 
Highlight the Blurred Background, go to Edit>Erase SelectionEdit>Erase SelectionEdit>Erase SelectionEdit>Erase Selection.  
If you are not entirely satisfied with the result undo the Erase Selection and either add paint or use 
the eraser to refine your selection. Make sure that you have the Red Mask highlighted when you do 
this and the marching ants are not active. Then just go through the steps again until you have exactly 
the result you are after. 
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8.8.8.8. Now for some plastic surgery. Highlight the “Photo Copy” and click on Duplicate Layer and call 
this layer “Cloning.” With this layer highlighted remove the visibility ticks from any layer above. Zoom 
in on your subject and select the CCCClonelonelonelone tool. Reduce the opacity of the tool for delicate work by 
reducing the opacity for the primary color in the colors window. I have reduced the opacity to 150. 
Control Click on the area you want to copy, and then click on the pixels you want to replace. 
  
Tip:-For delicate work with the Clone tool use a small brush size and play with the opacity settings for 
the brush. Control click close to the area you want to cover to get the best tonal range. Don’t drag the 
mouse but click, and regularly reselect your source pixels. It can be fiddly for a project like this but 
the results can be very rewarding 
Tip: - Whenever I want to make an alteration to a picture I prefer to do it on a duplicate layer. Not only 
does this preserve the original layer if I make a mess, but also allows me to compare the changes 
made. 

9.9.9.9. Next make another duplicate layer of the” Photo Copy” and call this” Defining mask.” Making 
sure it is highlighted and no layers are visible above it, chose the paint brushpaint brushpaint brushpaint brush tool and using black, 
paint over the features that you want to stand out, such as the eyes, lips, jaw line, pearls etc… Use 
the magic wandmagic wandmagic wandmagic wand to select each section holding down the control key so you can select more than one 
section. If you have a problem using the magic wand, ensure that the correct layer is highlighted and 
that the tolerance level is appropriate. Once you have all the black strokes highlighted go to 
Edit>Invert SelectionEdit>Invert SelectionEdit>Invert SelectionEdit>Invert Selection. Then on the “Cloning” layer below choose a Gaussian blur of 2, to soften the 
portrait while retaining the crispness of the highlighted areas. 

10.10.10.10. Next, the portrait needs a frame. Firstly, if I am going to have it printed in a standard size I need 
to make sure that the canvas has the ratios of the layout I am choosing. I want my portrait to be in a 
9cm x 13 cm frame. Click on image canvas size and change the canvas size to 450 X 650. 

11.11.11.11. Create a new layer and call it “Frame.” Drag the Ellipse SelectEllipse SelectEllipse SelectEllipse Select tool around the portrait and size 
and position it with the MMMMove Selectionove Selectionove Selectionove Selection tool. Have it come slightly inside the outline of the picture. 
Invert SelectionInvert SelectionInvert SelectionInvert Selection from the Edit menu, select the color picker, highlight the “Blurred Background” layer, 
and left click on a neutral color from the background in the photo for the foreground swatch color. 
Select the Paint BucketPaint BucketPaint BucketPaint Bucket and highlight the “Frame” layer and left mouse click inside the marching ants 
to fill the frame with that color.  

12.12.12.12. Go to Effects>Add NoiseEffects>Add NoiseEffects>Add NoiseEffects>Add Noise    and I chose an Intensity of 40 and a color saturation of 30. Then again 
go to Effects and this time I chose Oil Oil Oil Oil PaintingPaintingPaintingPainting    and I chose a brush size of 5 and a coarseness of 
100. Deselect. Save.Save.Save.Save. 

13.13.13.13. Create a new layer and call it “Border”, move it to just below the “Frame” layer and with it 
highlighted make another ellipse selection just inside the perimeter of the frame, about 2 – 3 pixels 
wide. Invert selection. Choose the color pickecolor pickecolor pickecolor picker tool and left click on a suitable color in the picture, 
with the “Photo CopyPhoto CopyPhoto CopyPhoto Copy”””” layer highlighted to obtain the clearest colour. I have chosen subtle light 
pinkish- mauve. Then highlight the “Border” layer and use the paint paint paint paint bucketbucketbucketbucket, to fill the layer with 
whatever color you have chosen. My finished masterpiece looks like this:- 

 

 

 

 

 

 

 

14.14.14.14. Before you finish your project you may want to adjust the various attributes such as Brightness 
and contrast, levels or curves. 

Tip: - You can achieve a number of effects using the different layer modes and adjusting the layer 
opacity. Try duplicating whichever layer you wish to adjust. Apply multiplymultiplymultiplymultiply to darken all pixels except 
the white ones, and/or ScreenScreenScreenScreen to lighten all pixels except the black ones, or OverlayOverlayOverlayOverlay which darkens the 
dark and lightens the light at the same time. Then adjust the opacity of the layer/s to get the result you 
want. 

15.15.15.15. I hope that these examples have helped to give you some idea of how to use the various tools 
and options in Paint.NET.  If you get stuck on anything, or would like to discuss or make any 
suggestions on using this program, please feel free to email me at kathythepetal@hotmail.com . 

 


